summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index c9dcf23fc3..ec244a811e 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -198,11 +198,12 @@ introspection_files = \
$(gdk_c_sources) \
gdkenumtypes.c \
gdkenumtypes.h \
- x11/*.c
+ x11/*.c \
+ x11/gdkx.h
Gdk-3.0.gir: $(gdktargetlib) Makefile
Gdk_3_0_gir_SCANNERFLAGS = --strip-prefix=Gdk --add-include-path=../gdk-pixbuf
-Gdk_3_0_gir_INCLUDES = Gio-2.0 GdkPixbuf-3.0 Pango-1.0
+Gdk_3_0_gir_INCLUDES = Gio-2.0 GdkPixbuf-3.0 Pango-1.0 xlib-2.0
Gdk_3_0_gir_LIBS = $(gdktargetlib)
Gdk_3_0_gir_FILES = $(addprefix $(srcdir)/,$(introspection_files))
Gdk_3_0_gir_CFLAGS = $(INCLUDES)