summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 39f07bbfaa..5962d18c81 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -30,15 +30,36 @@ libgdk_la_LDFLAGS = @STRIP_BEGIN@ \
#
# setup source file variables
#
+#
# GDK header files for public installation (non-generated)
+#
+# Note: files added here may need to be be propagated to gdk_headers in gtk/Makefile.am
+#
gdk_public_h_sources = @STRIP_BEGIN@ \
gdk.h \
+ gdkcc.h \
+ gdkcolor.h \
+ gdkcursor.h \
gdkcursors.h \
- gdkrgb.h \
- gdki18n.h \
+ gdkdnd.h \
+ gdkdrawable.h \
+ gdkevents.h \
+ gdkfont.h \
+ gdkgc.h \
gdkkeysyms.h \
+ gdki18n.h \
+ gdkim.h \
+ gdkimage.h \
+ gdkinput.h \
+ gdkpixmap.h \
gdkprivate.h \
+ gdkproperty.h \
+ gdkregion.h \
+ gdkrgb.h \
+ gdkselection.h \
gdktypes.h \
+ gdkvisual.h \
+ gdkwindow.h \
gdkx.h \
@STRIP_END@
gdk_c_sources = @STRIP_BEGIN@ \