summaryrefslogtreecommitdiff
path: root/examples/application2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/application2/Makefile.am')
-rw-r--r--examples/application2/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/application2/Makefile.am b/examples/application2/Makefile.am
new file mode 100644
index 0000000000..91e3c1903c
--- /dev/null
+++ b/examples/application2/Makefile.am
@@ -0,0 +1,30 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/gdk \
+ -I$(top_builddir)/gdk \
+ $(GTK_DEBUG_FLAGS) \
+ $(GTK_DEP_CFLAGS)
+
+LDADD = \
+ $(top_builddir)/gtk/libgtk-3.la \
+ $(top_builddir)/gdk/libgdk-3.la \
+ $(GTK_DEP_LIBS)
+
+
+noinst_PROGRAMS = exampleapp
+
+exampleapp_SOURCES = \
+ main.c \
+ exampleapp.c exampleapp.h \
+ exampleappwin.c exampleappwin.h \
+ resources.c
+
+BUILT_SOURCES = resources.c
+
+resources.c: exampleapp.gresource.xml window.ui
+ $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $(srcdir)/exampleapp.gresource.xml \
+ --target=$@ --sourcedir=$(srcdir) --generate-source
+
+EXTRA_DIST = \
+ window.ui \
+ exampleapp.gresource.xml