summaryrefslogtreecommitdiff
path: root/docs/reference/gdk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/gdk/Makefile.am')
-rw-r--r--docs/reference/gdk/Makefile.am26
1 files changed, 13 insertions, 13 deletions
diff --git a/docs/reference/gdk/Makefile.am b/docs/reference/gdk/Makefile.am
index e3dfbba41c..dcc8897245 100644
--- a/docs/reference/gdk/Makefile.am
+++ b/docs/reference/gdk/Makefile.am
@@ -6,8 +6,8 @@ DOC_MODULE=gdk
# The top-level SGML file.
DOC_MAIN_SGML_FILE=gdk-docs.sgml
-# The directory containing the source code (if it contains documentation).
-DOC_SOURCE_DIR=$(top_srcdir)/gdk
+# The directory containing the source code. Relative to $(srcdir)
+DOC_SOURCE_DIR=../../../gdk
# Extra options to supply to gtkdoc-scan
SCAN_OPTIONS=--deprecated-guards="GDK_ENABLE_BROKEN|GDK_DISABLE_DEPRECATED"
@@ -34,9 +34,9 @@ IGNORE_HFILES= \
win32 \
x11
-# Extra files to add when scanning
+# Extra files to add when scanning (relative to $srcdir)
EXTRA_HFILES= \
- $(top_srcdir)/gdk/x11/gdkx.h
+ ../../../gdk/x11/gdkx.h
# Images to copy into HTML directory
HTML_IMAGES =
@@ -87,14 +87,14 @@ all-local: html-build.stamp
scan-build.stamp: $(HFILE_GLOB)
@echo '*** Scanning header files ***'
- cd $(srcdir) && ( \
- if grep -l '^..*$$' $(DOC_MODULE).types > /dev/null ; then \
- CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj --module=$(DOC_MODULE) ; \
+ if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null ; then \
+ CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
else \
+ cd $(srcdir) ; \
for i in $(SCANOBJ_FILES) ; do \
test -f $$i || touch $$i ; \
done \
- fi )
+ fi
cd $(srcdir) && \
gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
touch scan-build.stamp
@@ -114,7 +114,7 @@ tmpl.stamp: tmpl-build.stamp
#### sgml ####
-sgml-build.stamp: tmpl.stamp $(CFILE_GLOB) tmpl/*.sgml
+sgml-build.stamp: tmpl.stamp $(CFILE_GLOB)
@echo '*** Building SGML ***'
cd $(srcdir) && \
gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) $(MKDB_OPTIONS)
@@ -174,12 +174,12 @@ dist-hook: dist-check-gtkdoc dist-hook-local
mkdir $(distdir)/html
-cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
-cp $(srcdir)/sgml/*.sgml $(distdir)/sgml
- -cp $(srcdir)/sgml/*.bottom $(srcdir)/sgml/*.top $(distdir)/sgml
-cp $(srcdir)/html/index.sgml $(distdir)/html
-cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
-# for i in $(HTML_IMAGES) ; do \
-# cp $(srcdir)/$$i $(distdir)/html ; \
-# done
+ images=$(HTML_IMAGES) ; \
+ for i in $$images ; do \
+ cp $(srcdir)/$$i $(distdir)/html ; \
+ done
.PHONY : dist-hook-local