summaryrefslogtreecommitdiff
path: root/demos/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'demos/meson.build')
-rw-r--r--demos/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/demos/meson.build b/demos/meson.build
index 42590368a2..79c530f4b7 100644
--- a/demos/meson.build
+++ b/demos/meson.build
@@ -1,3 +1,19 @@
+demo_conf = configuration_data()
+demo_conf.set_quoted('PROFILE', get_option('profile'))
+demo_conf.set_quoted('VCS_TAG', '@VCS_TAG@')
+
+demo_conf_h = declare_dependency(
+ sources: vcs_tag(
+ command: [ 'git', 'rev-parse', '--short', 'HEAD' ],
+ fallback: get_option('profile') != 'default' ? 'devel' : '',
+ input: configure_file(
+ output: 'demo_conf.h.in',
+ configuration: demo_conf
+ ),
+ output: 'demo_conf.h'
+ )
+)
+
subdir('constraint-editor')
subdir('gtk-demo')
subdir('icon-browser')