summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dcaf862642..fa0d741d7b 100644
--- a/configure.in
+++ b/configure.in
@@ -118,6 +118,14 @@ if test "x$enable_shm" = "xyes"; then
$x_libs)
fi
+# Check for shaped window extension
+
+AC_CHECK_LIB(Xext, XShapeCombineMask,
+ if test -z "`echo $x_libs | grep "\-lXext" 2> /dev/null`"; then
+ $x_libs="-lXext $x_libs"
+ fi
+ AC_DEFINE(HAVE_SHAPE_EXT))
+
x_cflags="$X_CFLAGS"
x_ldflags="$X_LDFLAGS $X_LIBS"