summaryrefslogtreecommitdiff
path: root/testsuite/reftests/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2019-04-12 20:58:29 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2019-04-12 20:58:29 +0100
commitf58f0732c2c9e4e4016102e23308753d7cde851c (patch)
tree7a3350e12adef49473596d0ba9bc99403bf3ad29 /testsuite/reftests/meson.build
parentc5a4a26f069305e58b8a4773802e9a7328d415c2 (diff)
downloadgtk+-f58f0732c2c9e4e4016102e23308753d7cde851c.tar.gz
ci: Cache the reftest artifacts
Keeping the reftest output images as artifacts of a job allows us to browse them and download them straight from GitLab.
Diffstat (limited to 'testsuite/reftests/meson.build')
-rw-r--r--testsuite/reftests/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/testsuite/reftests/meson.build b/testsuite/reftests/meson.build
index b91ec0927e..38c98cb6e7 100644
--- a/testsuite/reftests/meson.build
+++ b/testsuite/reftests/meson.build
@@ -427,7 +427,12 @@ xfails = [
foreach testname : testdata
if testname.endswith('.ui') and not testname.endswith('.ref.ui')
test('reftest ' + testname, gtk_reftest,
- args: [ '--tap', '-k', '--verbose', join_paths(meson.current_source_dir(), testname) ],
+ args: [ '--tap',
+ '-k',
+ '--verbose',
+ '-o', join_paths(meson.current_build_dir(), 'output'),
+ join_paths(meson.current_source_dir(), testname),
+ ],
env: [ 'GIO_USE_VOLUME_MONITOR=unix',
'GSETTINGS_BACKEND=memory',
'GSETTINGS_SCHEMA_DIR=@0@'.format(gtk_schema_build_dir),