summaryrefslogtreecommitdiff
path: root/testsuite/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-01-21 23:57:24 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-01-21 23:57:24 -0500
commite808fb424ae10baa31ba92a2e3bbec38689c246a (patch)
treecdae8d59e963102184769b55e04d3c137d4edfb6 /testsuite/meson.build
parent6c54abeca719cb98d6ce84c0c03114b426cb1c51 (diff)
downloadgtk+-e808fb424ae10baa31ba92a2e3bbec38689c246a.tar.gz
testsuite: Stop requiring diff
Unify the many copies of diff_with_file in one source file, and patch it to detect diff at runtime and fall back to a simple strcmp if we don't have it. Make all tests use this new testutils.c, and stop requiring diff for building the tests. This should let us allow to build on Windows with the default value for -Dbuild-tests.
Diffstat (limited to 'testsuite/meson.build')
-rw-r--r--testsuite/meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/testsuite/meson.build b/testsuite/meson.build
index 4ef7cced9a..fafe6ea140 100644
--- a/testsuite/meson.build
+++ b/testsuite/meson.build
@@ -2,10 +2,6 @@ gtk_libexecdir = join_paths(gtk_prefix, get_option('libexecdir'))
installed_test_bindir = join_paths(gtk_libexecdir, 'installed-tests', 'gtk-4.0')
installed_test_datadir = join_paths(gtk_datadir, 'installed-tests', 'gtk-4.0')
-# We call diff in various tests, so we need to check it's available,
-# otherwise we're going to have failures down the line
-diff = find_program('diff', required: true)
-
common_env = [
'GIO_USE_VOLUME_MONITOR=unix',
'GSETTINGS_BACKEND=memory',