summaryrefslogtreecommitdiff
path: root/testsuite/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-04-30 22:13:47 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:58 +0100
commita54b6be6061ea03f19910a10a5403ab69733ef5f (patch)
treed73e4031bb744c57613ad03aab8be52800f73bea /testsuite/meson.build
parent8acf5a8174978beeed3b75f6a0d718295e3f88fc (diff)
downloadgtk+-a54b6be6061ea03f19910a10a5403ab69733ef5f.tar.gz
build: Add common settings for tests
We are going to reuse them in the various parts of the test suite.
Diffstat (limited to 'testsuite/meson.build')
-rw-r--r--testsuite/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/testsuite/meson.build b/testsuite/meson.build
index fef8506bbd..481fa2f9aa 100644
--- a/testsuite/meson.build
+++ b/testsuite/meson.build
@@ -1,3 +1,15 @@
+installed_test_bindir = join_paths(get_option('libexecdir'), 'installed-tests', 'gtk-4.0')
+installed_test_datadir = join_paths(get_option('datadir'), 'installed-tests', 'gtk-4.0')
+
+installed_test_env = [
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'GIO_USE_VOLUME_MONITOR=unix',
+ 'GSETTINGS_BACKEND=memory',
+ 'GTK_CSD=1',
+ 'G_ENABLE_DIAGNOSTIC=0',
+]
+
subdir('gtk')
subdir('gdk')
subdir('css')