summaryrefslogtreecommitdiff
path: root/testsuite/a11y/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2017-10-18 16:55:02 +0800
committerMatthias Clasen <mclasen@redhat.com>2017-10-18 17:30:20 +0200
commit4a22704d82d5245cec9321b906941282fc714595 (patch)
tree81005273e0f39d19d23e7e0d8a08f0b16d525a43 /testsuite/a11y/meson.build
parentf8f94ab329b1deb8d315cdb8689203c7bb4d1906 (diff)
downloadgtk+-4a22704d82d5245cec9321b906941282fc714595.tar.gz
Fix test environments
Diffstat (limited to 'testsuite/a11y/meson.build')
-rw-r--r--testsuite/a11y/meson.build14
1 files changed, 10 insertions, 4 deletions
diff --git a/testsuite/a11y/meson.build b/testsuite/a11y/meson.build
index 8950e6f790..164eda40ab 100644
--- a/testsuite/a11y/meson.build
+++ b/testsuite/a11y/meson.build
@@ -1,3 +1,6 @@
+testexecdir = join_paths(installed_test_bindir, 'a11y')
+testdatadir = join_paths(installed_test_datadir, 'a11y')
+
a11y_tests = [
'accessibility-dump',
'tree-performance',
@@ -10,9 +13,6 @@ a11y_tests = [
'util',
]
-testexecdir = join_paths(installed_test_bindir, 'a11y')
-testdatadir = join_paths(installed_test_datadir, 'a11y')
-
foreach t: a11y_tests
test_prefix = 'a11y'
@@ -22,7 +22,13 @@ foreach t: a11y_tests
install_dir: testexecdir,
dependencies: libgtk_dep),
args: [ '--tap', '-k', ],
- env: installed_test_env,
+ env: [ 'GIO_USE_VOLUME_MONITOR=unix',
+ 'GSETTINGS_BACKEND=memory',
+ 'GTK_CSD=1',
+ 'G_ENABLE_DIAGNOSTIC=0',
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir())
+ ],
suite: 'a11y')
endforeach