summaryrefslogtreecommitdiff
path: root/testsuite/a11y/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-07-30 21:25:04 +0200
committerMatthias Clasen <mclasen@redhat.com>2014-08-04 09:58:58 +0200
commit944e30d940d5832df506a272828f356f8534b723 (patch)
tree0d78c88f154cb6cf1a0eebe09a6971c7cb0fe762 /testsuite/a11y/Makefile.am
parent45ca4bd0b2eb0ce90ec9e9c44fac4915b0e4bd70 (diff)
downloadgtk+-944e30d940d5832df506a272828f356f8534b723.tar.gz
Add a11y state tests
This adds a new test which can be scripted to trigger various event and action sequences, and record state changes in the accessibility layer. So far, there are a few tests verifying state changes when focus changes. Related to https://bugzilla.gnome.org/show_bug.cgi?id=715176
Diffstat (limited to 'testsuite/a11y/Makefile.am')
-rw-r--r--testsuite/a11y/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/testsuite/a11y/Makefile.am b/testsuite/a11y/Makefile.am
index 5762efa44a..e8ab6068a3 100644
--- a/testsuite/a11y/Makefile.am
+++ b/testsuite/a11y/Makefile.am
@@ -1,6 +1,8 @@
include $(top_srcdir)/Makefile.decl
NULL =
+SUBDIRS = state
+
check_PROGRAMS = $(TEST_PROGS)
AM_CPPFLAGS = \
@@ -39,11 +41,6 @@ TEST_PROGS += value
TEST_PROGS += misc
-# the focus test has no chance of working until
-# all the idle handlers in gail are gone
-#
-# TEST_PROGS += focus
-
TEST_PROGS += tree-relationships
TEST_PROGS += util