summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-01-21 13:59:12 -0500
committerMatthias Clasen <mclasen@redhat.com>2020-01-21 17:31:48 -0500
commitea17728ee5f9af0dc1ad96b4d6cbdff5f6d22831 (patch)
treec516837648c6f60ccd49ca4e5935db0958e0df56 /tests/meson.build
parenta6f300cefd2edfb7789e75565adb03f82a701530 (diff)
downloadgtk+-ea17728ee5f9af0dc1ad96b4d6cbdff5f6d22831.tar.gz
Prototype a sysprof helper
This is an attempt to see how we can use sysprof data in our tests to extract useful performance numbers. Use it as a wrapper around any GTK+ process: ./testperf ./gtk4-widget-factory Currently, it repeatedly runs the given commandline, extracts the first css validation time from the resulting syscap file, and prints out the min/max/avg of the runs at the end. This relies on the environment variable GTK_DEBUG_AUTO_QUIT to cause the process to exit soon after launch.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 37d6f0d87f..e7aa88ce87 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -150,4 +150,9 @@ foreach t: gtk_tests
dependencies: [libgtk_dep, libm])
endforeach
+
+
+executable('testperf', 'testperf.c',
+ dependencies: [profiler_dep, platform_gio_dep, libm])
+
subdir('visuals')