summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2019-10-23 19:13:11 -0700
committerChristian Hergert <chergert@redhat.com>2019-11-05 09:34:29 -0800
commit5e341210a1cfa08a34cb257039416a97a0ab4929 (patch)
tree6d5777a28391bc0744640bd10f0efa0f1dc096c3 /tests/meson.build
parentfbea677a5c6948684317f872bc6740f3c03e4b3b (diff)
downloadgtk+-5e341210a1cfa08a34cb257039416a97a0ab4929.tar.gz
texthistory: add GtkTextHistory helper
The GtkTextHistory helper provides the fundamental undo/redo stack that can be integrated with other text widgets. It allows coalescing related actions to reduce both the number of undo actions to the user as well as the memory overhead. A new istring helper is used by GtkTextHistory to allow for "inline strings" that gracefully grow to using allocations with g_realloc(). This ensure that most undo operations require no additional allocations other than the struct for the action itself. A queue of undoable and redoable actions are maintained and the link for the queue is embedded in the undo action union. This allows again, for reducing the number of allocations involved for undo operations.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 176685fe50..7b28428102 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -126,6 +126,7 @@ gtk_tests = [
['testblur'],
['testtexture'],
['testwindowdrag'],
+ ['testtexthistory', ['../gtk/gtktexthistory.c']],
]
if os_unix