summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMathias Hasselmann <mathias.hasselmann@gmx.de>2007-06-26 14:24:27 +0000
committerMathias Hasselmann <hasselmm@src.gnome.org>2007-06-26 14:24:27 +0000
commit07946bd70d51ebda070ec558314da7348b490934 (patch)
tree4e39c7d9a34e7c4c6dfa49a5a1dfe2a2093d7c6b /tests/Makefile.am
parentdac4d352114937b463c4f7d3627389de66d54241 (diff)
downloadgtk+-07946bd70d51ebda070ec558314da7348b490934.tar.gz
Extend the C++ keyword test to include internal GDK headers (#449016).
2007-06-22 Mathias Hasselmann <mathias.hasselmann@gmx.de> * configure.in, tests/Makefile.am, tests/autotestkeywords.cc, tests/dummy-headers/*: Extend the C++ keyword test to include internal GDK headers (#449016). svn path=/trunk/; revision=18244
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6080704e67..5f9bbf0090 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,10 +26,6 @@ endif
TESTS = floatingtest buildertest
-if HAVE_CXX
-TESTS += autotestkeywords
-endif
-
noinst_PROGRAMS = \
autotestfilechooser \
autotestkeywords \
@@ -95,7 +91,19 @@ noinst_PROGRAMS = \
testtooltips \
testvolumebutton
+if HAVE_CXX
+noinst_PROGRAMS += autotestkeywords
+TESTS += autotestkeywords
+
autotestkeywords_SOURCES = autotestkeywords.cc
+autotestkeywords_CPPFLAGS = -I$(srcdir)/dummy-headers
+
+if HAVE_OBJC
+autotestkeywords_CPPFLAGS += -DHAVE_OBJC=1
+autotestkeywords_CXXFLAGS = -x objective-c++
+endif
+
+endif
autotestfilechooser_DEPENDENCIES = $(TEST_DEPS)
simple_DEPENDENCIES = $(TEST_DEPS)