summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-05-06 21:55:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-05-06 21:55:41 +0000
commit629a0e14248812e55e9245bad9e01d9bc6bd2d0a (patch)
tree4805be6ed3f1fab22e7f536861e8e4f896e63b2c /tests/Makefile.am
parent2e58122c793a66f6241ff4bfe74e8966a043eeb3 (diff)
downloadgtk+-629a0e14248812e55e9245bad9e01d9bc6bd2d0a.tar.gz
Patch from James Henstridge to update to automake-1.7 (#109542)
Tue May 6 16:50:52 2003 Owen Taylor <otaylor@redhat.com> Patch from James Henstridge to update to automake-1.7 (#109542) * autogen.sh: update to call newer tools. * configure.in: various updates, to use M4 macros to put variables that change each release at the top. Use AC_HELP_STRING to format help strings. Use AC_CONFIG_COMMANDS to generate gdkconfig.h. * Makefile.am: require Automake 1.7. Remove gdk-2.0.pc and gtk+-2.0.pc on uninstall. Pass --enable-gtk-doc to configure during distcheck. * docs/reference/*/Makefile.am: simplify to use the gtk-doc.make makefile fragment. * */Makefile.am: don't use STRIP_BEGIN/STRIP_END. Use BUILT_SOURCES where appropriate. Build generated files in builddir rather than srcdir. Fix uninstall and distclean targets to satisfy distcheck. === * gdk/*/Makefile.am: Remove the hacks to get gdkenumtypes.h built first, since we are now using BUILT_SOURCES. * gdk/Makefile.am: Remove an outdated comment about gdk_headers. * demos/gtk-demo/Makefile.am: Fix srcdir != buildd problem with geninclude.pl. * configure.in: Update versions to 2.3.0.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am43
1 files changed, 19 insertions, 24 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3701f9a026..0838ed4b18 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,27 +1,25 @@
## Makefile.am for gtk+/tests
-INCLUDES = @STRIP_BEGIN@ \
- -I$(top_srcdir) \
- -I$(top_builddir)/gdk \
- -I$(top_srcdir)/gdk \
- -DG_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
- @GTK_DEBUG_FLAGS@ \
- @GTK_DEP_CFLAGS@ \
-@STRIP_END@
-
-DEPS = \
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir)/gdk \
+ -I$(top_srcdir)/gdk \
+ -DG_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ $(GTK_DEBUG_FLAGS) \
+ $(GTK_DEP_CFLAGS)
+
+DEPS = \
$(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
- $(top_builddir)/gdk/@gdktargetlib@ \
- $(top_builddir)/gtk/@gtktargetlib@
+ $(top_builddir)/gdk/$(gdktargetlib) \
+ $(top_builddir)/gtk/$(gtktargetlib)
-LDADDS = @STRIP_BEGIN@ \
+LDADDS = \
$(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
- $(top_builddir)/gdk/@gdktargetlib@ \
- $(top_builddir)/gtk/@gtktargetlib@ \
-@STRIP_END@
+ $(top_builddir)/gdk/$(gdktargetlib) \
+ $(top_builddir)/gtk/$(gtktargetlib)
if USE_X11
testsocket_programs = testsocket testsocket_child
@@ -128,7 +126,7 @@ testsocket_child_SOURCES = \
testsocket_child.c \
testsocket_common.c
-EXTRA_DIST = @STRIP_BEGIN@ \
+EXTRA_DIST = \
prop-editor.h \
testgtk.1 \
testgtkrc \
@@ -143,7 +141,4 @@ EXTRA_DIST = @STRIP_BEGIN@ \
test.xpm \
check-y.xpm \
check-n.xpm \
- test.xpm \
-@STRIP_END@
-
-
+ test.xpm