summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-05-03 00:46:19 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-05-03 00:46:19 +0000
commit4c2a74b79d0513ae9accfb8652b0ca47f5eab894 (patch)
tree6691b8b09b77760a16e995a8e781d6e063ffb214 /tests/Makefile.am
parenta5d1bc41ecb847f95ece2059d3ca0842f76076a1 (diff)
downloadgtk+-4c2a74b79d0513ae9accfb8652b0ca47f5eab894.tar.gz
Reduce new_text_length appropriately when we run into the size limit for
Wed May 2 20:36:38 2001 Owen Taylor <otaylor@redhat.com> * gtk/gtkentry.c (gtk_entry_real_insert_text): Reduce new_text_length appropriately when we run into the size limit for the entry. (#53445, reported by Jeff Franks) * tests/testgtk.c (create_entry): Remove most of the property toggle buttons. Replace with a "Props" button that brings up a property editor. * tests/prop-editor.[ch] test/testtreeview.c tests/Makefile.am: Split the property editor code out for reuse, improve.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2079d9ae89..2e7d20778f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -85,7 +85,16 @@ testtreesort_LDADD = $(LDADDS)
testtext_LDADD = $(LDADDS)
treestoretest_LDADD = $(LDADDS)
+testgtk_SOURCES = \
+ prop-editor.c \
+ testgtk.c
+
+testtreeview_SOURCES = \
+ prop-editor.c \
+ testtreeview.c
+
EXTRA_DIST += @STRIP_BEGIN@ \
+ prop-editor.h \
testgtk.1 \
testgtkrc \
testgtkrc2 \