summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSoeren Sandmann <sandmann@daimi.au.dk>2003-07-02 14:04:43 +0000
committerSøren Sandmann Pedersen <ssp@src.gnome.org>2003-07-02 14:04:43 +0000
commit2669847342d37bdbbe9107128579de090e1a121a (patch)
treeeab2a139c140c572b30d459c0215319c44c13c3a /tests/Makefile.am
parent39f5280dcbdd7611f9a57a1e7a472afe6b23b634 (diff)
downloadgtk+-2669847342d37bdbbe9107128579de090e1a121a.tar.gz
Add new toolbar headers
Wed Jul 2 15:42:26 2003 Soeren Sandmann <sandmann@daimi.au.dk> * gtk/gtk.h: Add new toolbar headers * tests/testtoolbar.c: new file * tests/Makefile.am (noinst_PROGRAMS): Add testtoolbar.c * gtk/gtkexpander.c (gtk_expander_class_init): Make it compile Tue Jul 1 22:49:25 2003 Soeren Sandmann <sandmann@daimi.au.dk> * gtk/gtktoolbar.c: (gtk_toolbar_remove_tool_item): Fix bug where list is changed inside a for loop (pointed out by Morten Welinder). (gtk_toolbar_focus_home_or_end): Minor formatting change Comments from Owen: * gtk/gtktoolbutton.c: remove copy of elide_underscores(). Use gtk_toolbar_elide_underscores instead. * gtk/gtktoolbar.c: rename signal from focus_ends to focus_home_or_end. (_gtk_toolbar_elide_underscores): export this as an internal function. (gtk_toolbar_move_focus): add comment explaining difference to gtk_toolbar_focus(); (gtk_toolbar_list_children_in_focus_order): Make TAB_FORWARD and TAB_BACKWARD focus the right widgets in RTL mode * gtk/gtktoolbutton.c (gtk_tool_button_new): Change to take "label" and "icon" parameters * gtk/gtktoolbutton.[ch]: remove icon_set property.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0838ed4b18..3cd09889d8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -40,6 +40,7 @@ noinst_PROGRAMS = \
$(testsocket_programs) \
testtext \
testtextbuffer \
+ testtoolbar \
testtreeedit \
testtreeview \
testtreefocus \
@@ -89,6 +90,7 @@ testselection_LDADD = $(LDADDS)
testsocket_LDADD = $(LDADDS)
testsocket_child_LDADD = $(LDADDS)
testtextbuffer_LDADD = $(LDADDS)
+testtoolbar_LDADD = $(LDADDS)
testtreeedit_LDADD = $(LDADDS)
testtreeview_LDADD = $(LDADDS)
testtreefocus_LDADD = $(LDADDS)
@@ -118,6 +120,10 @@ testtext_SOURCES = \
prop-editor.c \
testtext.c
+testtoolbar_SOURCES = \
+ testtoolbar.c \
+ prop-editor.c
+
testsocket_SOURCES = \
testsocket.c \
testsocket_common.c