summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2015-07-14 14:45:37 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2015-07-15 23:11:52 -0300
commit7af88d40b14f5793b975eab34e727ae4535d0cb7 (patch)
tree84304684731194ade26b0ef205ca04984315ef7f /tests/Makefile.am
parent72bfb40ccf746f743d9818f9dbecf2820f4557ba (diff)
downloadgtk+-7af88d40b14f5793b975eab34e727ae4535d0cb7.tar.gz
placesview: add view for fixed drives and networks
Places sidebar shows XDG directories, mounted and unmounted devices, connected networks, bookmarks and actions like 'Connect to server' and 'Insert location', which causes the sidebar to grow very quickly and look cluttered. Because of that, new mockups for the sidebar try to simplify it. To make the sidebar simpler, the new mockups propose that it should only handle connected networks and removable devices such as flash drives and USB devices, and delegates other devices for external widgets through the 'Other Locations' item. To handle fixed devices and manage network connections, add a new widget named GtkPlacesView, based on Nautilus mockups to keep consistency between GNOME file management tools - in this case, between Nautilus and the bundled Gtk's file chooser. https://bugzilla.gnome.org/show_bug.cgi?id=752034
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 233daa4064..07483c791a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -106,6 +106,7 @@ noinst_PROGRAMS = $(TEST_PROGS) \
testorientable \
testoverlay \
testoverlaystyleclass \
+ testplacesview \
testprint \
testrecentchooser \
testrecentchoosermenu \
@@ -253,6 +254,7 @@ testappchooserbutton_DEPENDENCIES = $(TEST_DEPS)
testorientable_DEPENDENCIES = $(TEST_DEPS)
testoverlay_DEPENDENCIES = $(TEST_DEPS)
testoverlaystyleclass_DEPENDENCIES = $(TEST_DEPS)
+testplacesview_DEPENDENCIES = $(TEST_DEPS)
testprint_DEPENDENCIES = $(TEST_DEPS)
testrecentchooser_DEPENDENCIES = $(TEST_DEPS)
testrecentchoosermenu_DEPENDENCIES = $(TEST_DEPS)
@@ -397,6 +399,9 @@ testtoolbar_SOURCES = \
testmenubutton_SOURCES = \
testmenubutton.c
+testplacesview_SOURCES = \
+ testplacesview.c
+
testprint_SOURCES = \
testprint.c \
testprintfileoperation.h \