summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
author13:38:36 Tim Janik <timj@imendio.com>2007-12-06 12:38:00 +0000
committerTim Janik <timj@src.gnome.org>2007-12-06 12:38:00 +0000
commit0a7a3f2fa2ab281a3e117ce17a56bb9723159520 (patch)
tree962125477f23fc4573f1825c2f643bb4c26507e3 /tests/Makefile.am
parent01a89326e84dbc26b0e320c2428fb48f599abcb7 (diff)
downloadgtk+-0a7a3f2fa2ab281a3e117ce17a56bb9723159520.tar.gz
ported to new testing framework.
2007-12-06 13:38:36 Tim Janik <timj@imendio.com> * tests/floatingtest.c: ported to new testing framework. * tests/Makefile.am: run floatingtest as testing framework test. svn path=/trunk/; revision=19118
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ccee78151b..4435750b50 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,7 +25,9 @@ if USE_X11
testsocket_programs = testsocket testsocket_child
endif
-
+TEST_PROGS += floatingtest
+floatingtest_DEPENDENCIES = $(TEST_DEPS)
+floatingtest_LDADD = $(LDADDS)
TEST_PROGS += objecttests
objecttests_SOURCES = objecttests.c
objecttests_LDADD = $(LDADDS)
@@ -36,11 +38,10 @@ autotestfilechooser_LDADD = $(LDADDS)
autotestfilechooser_SOURCES = autotestfilechooser.c
-TESTS = floatingtest buildertest
+TESTS = buildertest
noinst_PROGRAMS = $(TEST_PROGS) \
autotestkeywords \
- floatingtest \
buildertest \
simple \
print-editor \
@@ -117,7 +118,6 @@ endif
endif
simple_DEPENDENCIES = $(TEST_DEPS)
-floatingtest_DEPENDENCIES = $(TEST_DEPS)
buildertest_DEPENDENCIES = $(TEST_DEPS)
print_editor_DEPENDENCIES = $(TEST_DEPS)
testicontheme_DEPENDENCIES = $(TEST_DEPS)
@@ -173,7 +173,6 @@ testtooltips_DEPENDENCIES = $(TEST_DEPS)
testvolumebutton_DEPENDENCIES = $(TEST_DEPS)
simple_LDADD = $(LDADDS)
-floatingtest_LDADD = $(LDADDS)
buildertest_LDADD = $(LDADDS)
print_editor_LDADD = $(LDADDS)
testaccel_LDADD = $(LDADDS)