summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-10-23 21:55:20 -0400
committerMatthias Clasen <mclasen@redhat.com>2014-10-29 06:49:58 -0400
commita8cc4787d29c51823f0e07dbb46e7ba6400b04e4 (patch)
tree11e6643c1d2b6cd1c7e68f562d82d5d85aae7218 /tests/Makefile.am
parent83976c47f80f61c49bfa3dd6d3a16cad384053c6 (diff)
downloadgtk+-a8cc4787d29c51823f0e07dbb46e7ba6400b04e4.tar.gz
Add a manual popover menu example
Reproduce the testpopover popover manually, by packing model buttons into a stack in a popover.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b8355cfa25..b54084b290 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -9,7 +9,8 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/gdk \
$(GTK_DEBUG_FLAGS) \
$(GTK_DEP_CFLAGS) \
- $(GDK_DEP_CFLAGS)
+ $(GDK_DEP_CFLAGS) \
+ -pthread
DEPS = \
$(top_builddir)/gtk/libgtk-3.la
@@ -19,8 +20,12 @@ LDADD = \
$(top_builddir)/gdk/libgdk-3.la \
$(GTK_DEP_LIBS) \
$(GDK_DEP_LIBS) \
+ -lgmodule-2.0 \
-lm
+AM_LDFLAGS = -Wl,--export-dynamic -pthread
+
+
if USE_X11
testsocket_programs = testsocket testsocket_child
endif