summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-03-19 16:24:19 +0100
committerAlexander Larsson <alexl@redhat.com>2015-03-21 20:59:57 +0100
commit9ba185b749542618bc2843517d49dc05ed006164 (patch)
tree177c355162d725701e1dac10897da8b051f77fb3 /tests/Makefile.am
parentdd1af9bbdd13607454fb646093b8e3d9ef6f0423 (diff)
downloadgtk+-9ba185b749542618bc2843517d49dc05ed006164.tar.gz
Add performance test for gtkcairoblur
This just creates a large cairo surface and times bluring it at various values of radius. https://bugzilla.gnome.org/show_bug.cgi?id=746468
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c94448c507..c3bda57fce 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,6 +34,7 @@ noinst_PROGRAMS = $(TEST_PROGS) \
animated-revealing \
motion-compression \
scrolling-performance \
+ blur-performance \
simple \
flicker \
print-editor \
@@ -187,6 +188,7 @@ animated_revealing_DEPENDENCIES = $(TEST_DEPS)
flicker_DEPENDENCIES = $(TEST_DEPS)
motion_compression_DEPENDENCIES = $(TEST_DEPS)
scrolling_performance_DEPENDENCIES = $(TEST_DEPS)
+blur_performance_DEPENDENCIES = $(TEST_DEPS)
simple_DEPENDENCIES = $(TEST_DEPS)
print_editor_DEPENDENCIES = $(TEST_DEPS)
video_timer_DEPENDENCIES = $(TEST_DEPS)
@@ -318,6 +320,10 @@ scrolling_performance_SOURCES = \
variable.c \
variable.h
+blur_performance_SOURCES = \
+ blur-performance.c \
+ ../gtk/gtkcairoblur.c
+
video_timer_SOURCES = \
video-timer.c \
variable.c \