summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2011-04-07 02:15:42 +0200
committerBenjamin Otte <otte@redhat.com>2011-05-18 21:58:43 +0200
commit64fd32cdef9e55d35cf424c36b0f35ada736258d (patch)
treea8edf421d6b2e54f58e4ebd847123b49a8b5bd29 /tests/Makefile.am
parent9d9f1e38b2af6d3764f04ae5b42adf27c291fee5 (diff)
downloadgtk+-64fd32cdef9e55d35cf424c36b0f35ada736258d.tar.gz
tests: Add a test for the CSS parser
Tests in the parser need 1 or 2 files: 1) test.css 2) test.ref.css (optional, defaults to test.css) The test instantiates a CSS provider, loads test.css, then dumps the loaded file to test.out.css and then checks that that file matches test.ref.css. If not, it dumps a diff between those two to the log and fails. You want to run the test with --verbose to get the output dumped to stdout.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8c87a51460..fe077798d9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,7 +1,7 @@
## Makefile.am for gtk+/tests
include $(top_srcdir)/Makefile.decl
-SUBDIRS = reftests
+SUBDIRS = css reftests
INCLUDES = \
-I$(top_srcdir) \