summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2015-12-21 14:35:53 +0100
committerOlivier Fourdan <ofourdan@redhat.com>2016-01-08 10:33:26 +0100
commit28f011eb055673d8944cd6e012bc5d84bae41a26 (patch)
treef0e0e977653e30763e19471920f7b656b3b0e15a /tests/Makefile.am
parentd85b3fc60dcf09d4703b30bef676af93ef6ed6cd (diff)
downloadgtk+-28f011eb055673d8944cd6e012bc5d84bae41a26.tar.gz
wayland: prefer subsurface when possible
Quite a few applications use GTK_WINDOW_POPUP to create various temporary windows and place then on screen. That works fine on X11 but on Wayland there is no global coordinate system for regular surfaces. If the application is using a gdk temp window and set a parent with gtk_window_transient_for(), the gdk wayland backend has all it needs to create a subsurface that can be placed at will by the application. Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=759738
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f2123d97db..85d06bae6c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -170,6 +170,7 @@ noinst_PROGRAMS = $(TEST_PROGS) \
gdkgears \
listmodel \
foreigndrawing \
+ testpopup \
$(NULL)
if USE_X11