summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
author18:59:59 Tim Janik <timj@imendio.com>2007-12-05 16:58:44 +0000
committerTim Janik <timj@src.gnome.org>2007-12-05 16:58:44 +0000
commit9ba5da2f3644bdf5494a6b06dce7b6914e44b5af (patch)
tree3137551b1d0f3b9111b76d6c07c6381f2e24942c /tests/Makefile.am
parent4a82f84a28750dd37e03ffc9bbf4cf7fefc3a85a (diff)
downloadgtk+-9ba5da2f3644bdf5494a6b06dce7b6914e44b5af.tar.gz
run tests in current dir after setting up the logging directory, so their
2007-12-05 18:59:59 Tim Janik <timj@imendio.com> * gtk+/Makefile.decl: run tests in current dir after setting up the logging directory, so their results get properly merged into the resulting test log. * gtk+/gtk/gtktestutils.[hc]: added gtk_test_list_all_types() for tests to loop over registered Gdk/Gtk+ types. * gtk+/tests/objecttests.c: new test program, implements automated property tests. several properties are blacklisted because they seem to trigger Gdk/Gtk+ bugs. ./objecttests -m thorough --verbose can be used to test blacklisted properties and see which proprty failed. svn path=/trunk/; revision=19115
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d704321417..7f41e2eef8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,9 +25,16 @@ if USE_X11
testsocket_programs = testsocket testsocket_child
endif
+
+TEST_PROGS += objecttests
+objecttests_SOURCES = objecttests.c
+objecttests_LDADD = $(LDADDS)
+objecttests_DEPENDENCIES = $(TEST_DEPS)
+
+
TESTS = floatingtest buildertest
-noinst_PROGRAMS = \
+noinst_PROGRAMS = $(TEST_PROGS) \
autotestfilechooser \
autotestkeywords \
floatingtest \