summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@ximian.com>2005-07-29 00:38:51 +0000
committerFederico Mena Quintero <federico@src.gnome.org>2005-07-29 00:38:51 +0000
commitb4f52020f0fd86ddda88cdded1e4e84b47f384b6 (patch)
tree1b22478a6f40c3351474d546fb617f72b81418ec /perf/Makefile.am
parent375cb32bc107b1e69be49689fd096b1c961d94af (diff)
downloadgtk+-b4f52020f0fd86ddda88cdded1e4e84b47f384b6.tar.gz
Update for the new API of the profiler.
2005-07-28 Federico Mena Quintero <federico@ximian.com> * perf/README: Update for the new API of the profiler. * perf/gtkwidgetprofiler.[ch]: New files with a widget profiler object. This is the old content of timers.[ch] turned into a nice object, with signals for creation and reporting. The profiler needs to maintain some state when reusing the widget, so it's useful to turn it into a real object. Break down timing show_all into GTK_WIDGET_PROFILER_REPORT_MAP and GTK_WIDGET_PROFILER_REPORT_EXPOSE. * perf/main.c: Refactor to use GtkWidgetProfiler. * perf/appwindow.c (content_area_new): Make this just create a notebook, instead of a complex arrangement of panes. * perf/widgets.h: New header file for all the "create a widget" utility functions. * perf/treeview.c: New file. Moved the tree view part from appwindow.c over to here; GtkTreeView really needs its own tests. (tree_view_new): Set the shadow type to IN. * perf/textview.c: Likewise moved over from appwindow.c, but for GtkTextView. (text_view_new): Set the shadow type to IN. * perf/Makefile.am (testperf_SOURCES): Add the new source files; remove appwindow.h and timers.[ch]. * perf/timers.[ch]: Removed. * perf/appwindow.h: Removed.
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am79
1 files changed, 70 insertions, 9 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 8e7ae18611..046e544197 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -28,12 +28,73 @@ testperf_DEPENDENCIES = $(TEST_DEPS)
testperf_LDADD = $(LDADDS)
-testperf_SOURCES = \
- appwindow.c \
- appwindow.h \
- main.c \
- timers.c \
- timers.h
-
-EXTRA_DIST = \
- README
+testperf_SOURCES = \
+ appwindow.c \
+ gtkwidgetprofiler.c \
+ gtkwidgetprofiler.h \
+ main.c \
+ marshalers.c \
+ marshalers.h \
+ textview.c \
+ treeview.c \
+ typebuiltins.c \
+ typebuiltins.h \
+ widgets.h
+
+BUILT_SOURCES = \
+ marshalers.c \
+ marshalers.h \
+ typebuiltins.c \
+ typebuiltins.h
+
+stamp_files = \
+ stamp-marshalers.h \
+ stamp-typebuiltins.h
+
+headers_with_enums = \
+ gtkwidgetprofiler.h
+
+MAINTAINERCLEANFILES = $(BUILT_SOURCES) $(stamp_files)
+
+marshalers.h: stamp-marshalers.h
+ @true
+
+stamp-marshalers.h: @REBUILD@ marshalers.list
+ $(GLIB_GENMARSHAL) --prefix=_gtk_marshal $(srcdir)/marshalers.list --header >> xgen-gmlh \
+ && (cmp -s xgen-gmlh marshalers.h || cp xgen-gmlh marshalers.h) \
+ && rm -f xgen-gmlh \
+ && echo timestamp > $(@F)
+marshalers.c: @REBUILD@ marshalers.list
+ $(GLIB_GENMARSHAL) --prefix=_gtk_marshal $(srcdir)/marshalers.list --body >> xgen-gmlc \
+ && cp xgen-gmlc marshalers.c \
+ && rm -f xgen-gmlc
+
+typebuiltins.h: stamp-typebuiltins.h
+ @true
+stamp-typebuiltins.h: @REBUILD@ $(headers_with_enums) Makefile
+ ( cd $(srcdir) && glib-mkenums \
+ --fhead "#ifndef __TYPE_BUILTINS_H__\n#define __TYPE_BUILTINS_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
+ --fprod "/* enumerations from \"@filename@\" */\n" \
+ --vhead "GType @enum_name@_get_type (void) G_GNUC_CONST;\n#define GTK_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
+ --ftail "G_END_DECLS\n\n#endif /* __TYPE_BUILTINS_H__ */" \
+ $(headers_with_enums) ) >> xgen-gtbh \
+ && (cmp -s xgen-gtbh typebuiltins.h || cp xgen-gtbh typebuiltins.h ) \
+ && rm -f xgen-gtbh \
+ && echo timestamp > $(@F)
+typebuiltins.c: @REBUILD@ $(headers_with_enums) Makefile
+ ( cd $(srcdir) && glib-mkenums \
+ --fhead "#include \"gtkwidgetprofiler.h\"" \
+ --ftail "#define __TYPE_BUILTINS_C__\n" \
+ --fprod "\n/* enumerations from \"@filename@\" */" \
+ --vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \
+ --vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
+ --vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (\"@EnumName@\", values);\n }\n return etype;\n}\n" \
+ $(headers_with_enums) ) > xgen-gtbc \
+ && cp xgen-gtbc typebuiltins.c \
+ && rm -f xgen-gtbc
+
+
+EXTRA_DIST = \
+ README \
+ marshalers.list \
+ $(BUILT_SOURCES)