summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@ximian.com>2005-07-26 18:46:01 +0000
committerFederico Mena Quintero <federico@src.gnome.org>2005-07-26 18:46:01 +0000
commit4b4c0fe86c4a12e676a1742adcfaa5b76f590bec (patch)
tree5b906d8c4b0b230be7e58769c98761b14b1ffd5b /perf/Makefile.am
parent98a1367afe28745fcc51c36573aa643344ad42f4 (diff)
downloadgtk+-4b4c0fe86c4a12e676a1742adcfaa5b76f590bec.tar.gz
New directory with the start of a framework for testing performance in
2005-07-26 Federico Mena Quintero <federico@ximian.com> * perf/: New directory with the start of a framework for testing performance in GTK+. * Makefile.am (SRC_SUBDIRS): Added the perf directory. * configure.in (AC_OUTPUT): Generate perf/Makefile.
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
new file mode 100644
index 0000000000..8e7ae18611
--- /dev/null
+++ b/perf/Makefile.am
@@ -0,0 +1,39 @@
+## Makefile.am for gtk+/perf
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir)/gdk \
+ -I$(top_srcdir)/gdk \
+ -DG_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ $(GTK_DEBUG_FLAGS) \
+ $(GTK_DEP_CFLAGS)
+
+DEPS = \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
+ $(top_builddir)/gdk/$(gdktargetlib) \
+ $(top_builddir)/gtk/$(gtktargetlib)
+
+LDADDS = \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
+ $(top_builddir)/gdk/$(gdktargetlib) \
+ $(top_builddir)/gtk/$(gtktargetlib)
+
+noinst_PROGRAMS = \
+ testperf
+
+testperf_DEPENDENCIES = $(TEST_DEPS)
+
+testperf_LDADD = $(LDADDS)
+
+testperf_SOURCES = \
+ appwindow.c \
+ appwindow.h \
+ main.c \
+ timers.c \
+ timers.h
+
+EXTRA_DIST = \
+ README