summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
authorKalev Lember <kalev@smartlink.ee>2011-04-29 11:42:20 +0300
committerColin Walters <walters@verbum.org>2011-04-29 10:11:05 -0400
commit95904a5a1bd497bc3f7606285301e1ef873ce7fc (patch)
treeae1f0832735382478b492600ddf3228342b5b933 /perf/Makefile.am
parent5642703b0edf146046213f47d7e725adb4b1af9f (diff)
downloadgtk+-95904a5a1bd497bc3f7606285301e1ef873ce7fc.tar.gz
perf: Use different marshaller prefix than in gtk
Avoids multiple symbol definitions in gtk/gtkmarshalers.c and perf/marshalers.c when both objects are linked in. https://bugzilla.gnome.org/show_bug.cgi?id=648926
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 9a35a17830..799b748eab 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -57,12 +57,12 @@ marshalers.h: stamp-marshalers.h
@true
stamp-marshalers.h: @REBUILD@ marshalers.list
- $(GLIB_GENMARSHAL) --prefix=_gtk_marshal $(srcdir)/marshalers.list --header >> xgen-gmlh \
+ $(GLIB_GENMARSHAL) --prefix=_testperf_marshal $(srcdir)/marshalers.list --header >> xgen-gmlh \
&& (cmp -s xgen-gmlh marshalers.h || cp xgen-gmlh marshalers.h) \
&& rm -f xgen-gmlh \
&& echo timestamp > $(@F)
marshalers.c: @REBUILD@ marshalers.list
- $(GLIB_GENMARSHAL) --prefix=_gtk_marshal $(srcdir)/marshalers.list --body >> xgen-gmlc \
+ $(GLIB_GENMARSHAL) --prefix=_testperf_marshal $(srcdir)/marshalers.list --body >> xgen-gmlc \
&& cp xgen-gmlc marshalers.c \
&& rm -f xgen-gmlc