summaryrefslogtreecommitdiff
path: root/modules/engines/pixbuf/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2004-11-28 17:21:06 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-11-28 17:21:06 +0000
commitde33692b058f1d2c49de95a656985020fd74cfc8 (patch)
tree765f2ad92c3ac621fc8a16dba2222ee32e3b01f0 /modules/engines/pixbuf/Makefile.am
parentc50066b452babcfeeefff746c5161fec9d88baf6 (diff)
downloadgtk+-de33692b058f1d2c49de95a656985020fd74cfc8.tar.gz
Add necessary libraries to make it compile with -no-undefined. (#159713,
2004-11-28 Matthias Clasen <mclasen@redhat.com> * Makefile.am (LDADDS): Add necessary libraries to make it compile with -no-undefined. (#159713, Robert Ă–gren)
Diffstat (limited to 'modules/engines/pixbuf/Makefile.am')
-rw-r--r--modules/engines/pixbuf/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/modules/engines/pixbuf/Makefile.am b/modules/engines/pixbuf/Makefile.am
index 0dc2a730af..c641f79abc 100644
--- a/modules/engines/pixbuf/Makefile.am
+++ b/modules/engines/pixbuf/Makefile.am
@@ -11,6 +11,12 @@ INCLUDES = \
-DGDK_DISABLE_DEPRECATED \
$(GTK_DEP_CFLAGS)
+LDADDS = \
+ $(GTK_DEP_LIBS) \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-2.0.la \
+ $(top_builddir)/gdk/$(gdktargetlib) \
+ $(top_builddir)/gtk/$(gtktargetlib)
+
enginedir = $(libdir)/gtk-2.0/$(GTK_BINARY_VERSION)/engines
engine_LTLIBRARIES = libpixmap.la
@@ -25,5 +31,5 @@ libpixmap_la_SOURCES = \
pixbuf.h
libpixmap_la_LDFLAGS = -avoid-version -module $(no_undefined)
-libpixmap_la_LIBADD = $(GTK_LIBS)
+libpixmap_la_LIBADD = $(LDADDS)