summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2020-07-04 11:40:21 -0700
committerChristian Hergert <chergert@redhat.com>2020-07-28 11:22:33 -0700
commit459af3acab2ef82ecd12356484df42afdd59f9ee (patch)
tree295210cef52d0e3fbedf56d2ae6433e24a321da3 /meson.build
parentcc50be971dfc181925c4cf46b07912b8d487d9d8 (diff)
downloadgtk+-459af3acab2ef82ecd12356484df42afdd59f9ee.tar.gz
build: bump to sysprof 4 ABI
Sysprof has moved to a new ABI which removes GLib from the capture library so that GLib itself can link against sysprof-capture. This bumps the library ABI so we can keep things coordinated between all the new tracing layers in the stack.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 14 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3ab900eb06..71d7fd399f 100644
--- a/meson.build
+++ b/meson.build
@@ -687,7 +687,20 @@ endif
profiler_enabled = get_option('profiler')
if profiler_enabled
- profiler_dep = dependency('sysprof-capture-3', static: true, required: true)
+ # libsysprof-capture support
+ profiler_dep = dependency('sysprof-capture-4',
+ required: true,
+ default_options: [
+ 'enable_examples=false',
+ 'enable_gtk=false',
+ 'enable_tests=false',
+ 'enable_tools=false',
+ 'libsysprof=false',
+ 'with_sysprofd=none',
+ 'help=false',
+ ],
+ fallback: ['sysprof', 'libsysprof_capture_dep'],
+ )
if profiler_dep.found()
cdata.set('HAVE_SYSPROF_CAPTURE', profiler_dep.found())
else