summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2021-04-02 03:05:40 +0200
committerMatthias Clasen <mclasen@redhat.com>2021-07-20 14:00:25 -0400
commit0ae2acfb1a72675ed994fed7900e2a57e02bc733 (patch)
tree3b4cc763f2fd4c29532a7f1e78010c264165e83f /meson.build
parentafc5f46ca90e65009522946fdc929d259e0d51ec (diff)
downloadgtk+-0ae2acfb1a72675ed994fed7900e2a57e02bc733.tar.gz
x11: Remove XComposite
It's only used during DND to allow use of the root window's cow window as a DND target, because apparently gnome-shell used to think that was a great idea to DND to the overview. Somebody complain to gnome-shell devs about it not being a good idea if they want it fixed. Potentially using Wayland is a better idea though. This reverts 85ae875dcbfcfa3fbdca857dc90467d39b9ff0c5 Related: https://bugzilla.gnome.org/show_bug.cgi?id=601731
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index f3e4fa1a2a..8cabfefe7d 100644
--- a/meson.build
+++ b/meson.build
@@ -500,14 +500,12 @@ if x11_enabled
xcursor_dep = dependency('xcursor')
xdamage_dep = dependency('xdamage')
xfixes_dep = dependency('xfixes')
- xcomposite_dep = dependency('xcomposite')
fontconfig_dep = dependency('fontconfig')
- x11_pkgs = ['fontconfig', 'x11', 'xext', 'xi', 'xrandr', 'xcursor', 'xdamage', 'xfixes', 'xcomposite', 'xinerama']
+ x11_pkgs = ['fontconfig', 'x11', 'xext', 'xi', 'xrandr', 'xcursor', 'xdamage', 'xfixes', 'xinerama']
cdata.set('HAVE_XCURSOR', 1)
cdata.set('HAVE_XDAMAGE', 1)
- cdata.set('HAVE_XCOMPOSITE', 1)
cdata.set('HAVE_XFIXES', 1)
if not cc.has_function('XkbQueryExtension', dependencies: x11_dep,