summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-03-26 11:48:30 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-03-27 12:47:05 +0100
commit69441cbaceae6fa1b5f2df150609fe59b2a67cea (patch)
treea0fb11b91fd13f7dd7f7d1cccd0e90f8f283bed1 /meson.build
parentb9445f4d7e763140b0eab56c1ad0ee0945e216d7 (diff)
downloadgtk+-69441cbaceae6fa1b5f2df150609fe59b2a67cea.tar.gz
Do not test for linker flags
Meson warns when doing that, as it's not really portable. Since we're using platform-specific linker flags on Darwin, we can also do the same on Linux; the syntax is GCC-specific, so we're going to need Clang users to test it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 26d522fa3b..5831dfcbfe 100644
--- a/meson.build
+++ b/meson.build
@@ -279,12 +279,8 @@ endif
common_ldflags = []
-if host_machine.system() == 'linux'
- foreach ldflag: [ '-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now', ]
- if cc.has_argument(ldflag)
- common_ldflags += [ ldflag ]
- endif
- endforeach
+if host_machine.system() == 'linux' and cc.get_id() == 'gcc'
+ common_ldflags += [ '-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now', ]
endif
# Maintain compatibility with autotools