summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2019-02-04 18:07:14 -0500
committerMatthias Clasen <mclasen@redhat.com>2019-02-04 18:28:31 -0500
commitdbd360262cf8a56477dafea4293b2d9cec62bae7 (patch)
tree5e36b6fa76d8531fe16354127f3322e16960c0b6 /meson.build
parent25e199e7b789894f020ec740ff4a9419207f6a61 (diff)
downloadgtk+-dbd360262cf8a56477dafea4293b2d9cec62bae7.tar.gz
Add an explicit fribidi dep
We will use fribidi api to determine text direction.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0385d15b07..6579ee4f27 100644
--- a/meson.build
+++ b/meson.build
@@ -28,6 +28,7 @@ endif
glib_req = '>= @0@.@1@.@2@'.format(glib_major_req, glib_minor_req, glib_micro_req)
pango_req = '>= 1.41.0'
+fribidi_req = '>= 0.19.7'
atk_req = '>= 2.15.1'
cairo_req = '>= 1.14.0'
gdk_pixbuf_req = '>= 2.30.0'
@@ -325,6 +326,8 @@ cairo_dep = dependency('cairo', version: cairo_req, required : cc.get_id()
cairogobj_dep = dependency('cairo-gobject', version: cairo_req, required : cc.get_id() != 'msvc')
pango_dep = dependency('pango', version: pango_req,
fallback : ['pango', 'libpango_dep'])
+fribidi_dep = dependency('fribidi', version: fribidi_req,
+ fallback : ['fribidi', 'libfribidi_dep'])
# Require PangoFT2 if on X11 or wayland
require_pangoft2 = wayland_enabled or x11_enabled