summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-05 14:35:34 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-05 14:35:34 +0000
commit00990ec3072bfe6be20117e973adb123fc3c36ee (patch)
tree2ad67c8581ec73cec889dc7ae94802cb950234f6 /meson.build
parenta5363b9e5dea21226ee8224cb9c2e80a60c03dc6 (diff)
downloadgtk+-00990ec3072bfe6be20117e973adb123fc3c36ee.tar.gz
build: Fix the non-pkg-config Vulkan detection
Not all the variables were renamed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d7e7a72bde..3c7972d87a 100644
--- a/meson.build
+++ b/meson.build
@@ -568,7 +568,7 @@ else
vulkan_libname = 'vulkan'
endif
vulkan_dep = cc.find_library(vulkan_libname, required: false)
- if vulkan_lib.found() and cc.has_function('vkCreateInstance', dependencies: vulkan_lib) and cc.has_header('vulkan/vulkan.h')
+ if vulkan_dep.found() and cc.has_function('vkCreateInstance', dependencies: vulkan_dep) and cc.has_header('vulkan/vulkan.h')
have_vulkan = true
pc_gdk_extra_libs += ['-l@0@'.format(vulkan_libname)]
endif