summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-03-27 13:15:21 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-03-29 11:37:30 +0100
commitd50708b02406f650b65f48f18eaa2047632759d5 (patch)
tree86dc23ad407fd080d3c1c9b788addbec16957e97 /meson.build
parent934354fb8c024a4b0f0508863c98776e28a2ad98 (diff)
downloadgtk+-d50708b02406f650b65f48f18eaa2047632759d5.tar.gz
Add an option for building examples
Examples are not like demos; the latter are installed, and provide a Flatpak manifest for CI pipelines and GNOME Builder. We should not be using a single configure time option to gate building both.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index b5c4fa166e..9500d85d86 100644
--- a/meson.build
+++ b/meson.build
@@ -621,14 +621,16 @@ subdir('gdk')
subdir('gsk')
subdir('gtk')
subdir('modules')
-if get_option('demos')
- subdir('demos')
- subdir('examples')
-endif
if get_option('build-tests')
subdir('tests')
subdir('testsuite')
endif
+if get_option('demos')
+ subdir('demos')
+endif
+if get_option('build-examples')
+ subdir('examples')
+endif
# config.h
configure_file(input: 'config.h.meson',