summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-05-29 10:52:38 -0400
committerChristoph Reiter <reiter.christoph@gmail.com>2020-05-30 15:47:56 +0200
commitb482b7d8af073fd43e3e0a1ba5cf40fce33c6c34 (patch)
treee763c0780575d86701e5a4a6144f9c6db1fa43c5 /meson.build
parent011f5afe4eb82b9b4ab323315ea5dc27e55743d0 (diff)
downloadgtk+-b482b7d8af073fd43e3e0a1ba5cf40fce33c6c34.tar.gz
Bump the pango dependency
We soon want to rely on the list model apis in pango 1.45. This commit also fixes a mixup where using pango as a submodule would break the build when pangoft2 is required.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 486ea08672..fc0b1ef7fc 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ else
endif
glib_req = '>= @0@.@1@.@2@'.format(glib_major_req, glib_minor_req, glib_micro_req)
-pango_req = '>= 1.44.4'
+pango_req = '>= 1.45.0'
fribidi_req = '>= 0.19.7'
atk_req = '>= 2.15.1'
cairo_req = '>= 1.14.0'
@@ -352,10 +352,11 @@ fribidi_dep = dependency('fribidi', version: fribidi_req,
# Require PangoFT2 if on X11 or wayland
require_pangoft2 = wayland_enabled or x11_enabled
-pangoft_dep = dependency('pangoft2', required: false)
if require_pangoft2
pangoft_dep = dependency('pangoft2', fallback : ['pango', 'libpangoft2_dep'])
+else
+ pangoft_dep = dependency('pangoft2', required: false)
endif
if win32_enabled