summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-05-30 08:55:21 -0400
committerMatthias Clasen <mclasen@redhat.com>2020-05-30 08:55:21 -0400
commit821a458393a6f43589428e2891545ecfa7ba2919 (patch)
tree66fb70a37ea4ff1770702bdd80a502027a1aca6c /meson.build
parent66120cff4b4d9685a093bba7f201a1c025aadcf9 (diff)
downloadgtk+-821a458393a6f43589428e2891545ecfa7ba2919.tar.gz
Revert "Bump the pango dependency"
This reverts commit 98df0be43dea6ff61aadb28e1823b11a6d53452a. It broke the win32 build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fc0b1ef7fc..486ea08672 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ else
endif
glib_req = '>= @0@.@1@.@2@'.format(glib_major_req, glib_minor_req, glib_micro_req)
-pango_req = '>= 1.45.0'
+pango_req = '>= 1.44.4'
fribidi_req = '>= 0.19.7'
atk_req = '>= 2.15.1'
cairo_req = '>= 1.14.0'
@@ -352,11 +352,10 @@ fribidi_dep = dependency('fribidi', version: fribidi_req,
# Require PangoFT2 if on X11 or wayland
require_pangoft2 = wayland_enabled or x11_enabled
+pangoft_dep = dependency('pangoft2', required: false)
if require_pangoft2
pangoft_dep = dependency('pangoft2', fallback : ['pango', 'libpangoft2_dep'])
-else
- pangoft_dep = dependency('pangoft2', required: false)
endif
if win32_enabled