summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <creiter@src.gnome.org>2019-05-25 18:27:32 +0200
committerChristoph Reiter <creiter@src.gnome.org>2019-05-25 18:33:01 +0200
commit758830e7c33573b5393e03137dab659768695f5a (patch)
treec9caed4b96bc2f1e63a779006bd8a6b51efb9649 /meson.build
parente95e39cbd3ccb85dd9687bc998457f56bbf9ac75 (diff)
downloadgtk+-758830e7c33573b5393e03137dab659768695f5a.tar.gz
meson: allow building man pages without the documentation
The 'documentation' option also guarded the man page build. Instead if skipping the whole docs subdir skip the specific gtkdoc calls, so that the man page build still works. This brings it in line with the gtk3 meson build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 2189ee8b61..97cc7fdf28 100644
--- a/meson.build
+++ b/meson.build
@@ -790,10 +790,8 @@ endif
subdir('po')
subdir('po-properties')
-if get_option('documentation')
- subdir('docs/tools')
- subdir('docs/reference')
-endif
+subdir('docs/tools')
+subdir('docs/reference')
# Keep this in sync with post-install.sh expected arguments
meson.add_install_script('build-aux/meson/post-install.py',
@@ -815,6 +813,7 @@ summary = [
' Colord support: @0@'.format(get_option('colord')),
' Introspection: @0@'.format(get_option('introspection')),
' Documentation: @0@'.format(get_option('documentation')),
+ ' Man pages: @0@'.format(get_option('man-pages')),
' Build tests: @0@'.format(get_option('build-tests')),
' Install tests: @0@'.format(get_option('install-tests')),
' Demos: @0@'.format(get_option('demos')),