summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-04-14 09:15:31 -0400
committerMatthias Clasen <mclasen@redhat.com>2020-04-14 09:15:31 -0400
commit6870159c1d5a81f9ddf30e6a441783ffb2cf1f7d (patch)
treeb8f577cf2bd38fbfedb606387f9b6ceb27d5f25f /meson.build
parentd802b35578f7982a37c7f2fb4cac56c85ce133dd (diff)
downloadgtk+-6870159c1d5a81f9ddf30e6a441783ffb2cf1f7d.tar.gz
build: Prepare library versioning
Set version and soversion separately for the library. When we do the 4.0 release, we will set: gtk_soversion = '1' gtk_library_version = '1.0.0' See https://gitlab.gnome.org/GNOME/gtk/-/issues/1963
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ecf4228b40..d471be510d 100644
--- a/meson.build
+++ b/meson.build
@@ -85,7 +85,8 @@ gtk_binary_version = '4.0.0'
gtk_binary_age = 100 * gtk_minor_version + gtk_micro_version
-gtk_soversion = '0.@0@.@1@'.format(gtk_binary_age - gtk_interface_age, gtk_interface_age)
+gtk_soversion = '0'
+gtk_library_version = '0.@0@.@1@'.format(gtk_binary_age - gtk_interface_age, gtk_interface_age)
gtk_api_version = '4.0'