summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2019-02-05 08:29:39 +0000
committerMatthias Clasen <mclasen@redhat.com>2019-02-05 08:29:39 +0000
commit1aeeefdccbefcd084526fd6254094a118f7d398e (patch)
treed437cf39f54e86cca048572853746512913262a8 /meson.build
parentdcda16a26ff9df4ff522ad125a077cd7a2e8e409 (diff)
parentd080be3e5091c98d5171063a95d55c01170881f3 (diff)
downloadgtk+-1aeeefdccbefcd084526fd6254094a118f7d398e.tar.gz
Merge branch 'drop-the-plus' into 'master'
Rename some references to GTK+ See merge request GNOME/gtk!553
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 6579ee4f27..c2bd69710b 100644
--- a/meson.build
+++ b/meson.build
@@ -867,27 +867,27 @@ pkgconf.set('GTK_EXTRA_CFLAGS', '')
pkg_install_dir = join_paths(get_option('libdir'), 'pkgconfig')
-pkgs = [ 'gtk+-4.0.pc' ]
+pkgs = [ 'gtk4.pc' ]
pkg_targets = ''
foreach backend: [ 'broadway', 'quartz', 'wayland', 'win32', 'x11', ]
if get_variable('@0@_enabled'.format(backend))
- pkgs += ['gtk+-@0@-4.0.pc'.format(backend)]
+ pkgs += ['gtk4-@0@.pc'.format(backend)]
pkg_targets += ' ' + backend
endif
endforeach
pkgconf.set('GDK_BACKENDS', pkg_targets.strip())
foreach pkg: pkgs
- configure_file(input: 'gtk+-4.0.pc.in',
+ configure_file(input: 'gtk4.pc.in',
output: pkg,
configuration: pkgconf,
install_dir: pkg_install_dir)
endforeach
if os_unix
- configure_file(input: 'gtk+-unix-print-4.0.pc.in',
- output: 'gtk+-unix-print-4.0.pc',
+ configure_file(input: 'gtk4-unix-print.pc.in',
+ output: 'gtk4-unix-print.pc',
configuration: pkgconf,
install_dir: pkg_install_dir)
endif
@@ -910,7 +910,7 @@ meson.add_install_script('build-aux/meson/post-install.sh',
summary = [
'',
'------',
- 'GTK+ @0@ (@1@)'.format(gtk_version, gtk_api_version),
+ 'GTK @0@ (@1@)'.format(gtk_version, gtk_api_version),
'',
' Display backends: @0@'.format(pkg_targets.strip()),
' Print backends: @0@'.format(' '.join(print_backends)),