summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2018-04-15 21:11:57 -0400
committerMatthias Clasen <mclasen@redhat.com>2018-04-15 22:03:38 -0400
commit651e7aa6a140e0816518ccfbc82dfa36e26bae93 (patch)
tree72465f38ec65a547a414702006b6991f5f0340d5 /meson.build
parent5b160efc768d33b093ab9e041d091ac97551e3bf (diff)
downloadgtk+-651e7aa6a140e0816518ccfbc82dfa36e26bae93.tar.gz
Spruce up config summary
Show all the options. Nothing to hide.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 8 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 2a30d34a5f..8872d58fbd 100644
--- a/meson.build
+++ b/meson.build
@@ -750,13 +750,18 @@ summary = [
'------',
'GTK+ @0@ (@1@)'.format(gtk_version, gtk_api_version),
'',
- ' Enabled backends: @0@'.format(pkg_targets.strip()),
- ' Vulkan support: @0@'.format(have_vulkan),
+ ' Display backends: @0@'.format(pkg_targets.strip()),
' Print backends: @0@'.format(' '.join(print_backends)),
' Media backends: @0@'.format(' '.join(media_backends)),
- ' Tests: @0@'.format(get_option('build-tests')),
+ ' Vulkan support: @0@'.format(have_vulkan),
+ ' Cloud support: @0@'.format(get_option('cloudproviders')),
+ ' Colord support: @0@'.format(get_option('colord')),
+ ' Introspection: @0@'.format(get_option('introspection')),
' Documentation: @0@'.format(get_option('documentation')),
+ ' Build tests: @0@'.format(get_option('build-tests')),
+ ' Install tests: @0@'.format(get_option('install-tests')),
' Demos: @0@'.format(get_option('demos')),
+ ' Examples: @0@'.format(get_option('demos')),
'Directories:',
' prefix: @0@'.format(gtk_prefix),
' includedir: @0@'.format(gtk_includedir),