summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-04-06 23:59:33 +0000
committerMatthias Clasen <mclasen@redhat.com>2020-04-06 23:59:33 +0000
commitbaeae71d12d36c20f6dbe7d780bf5a8c55f4832a (patch)
treefe29e8e8b681ace8cc507ebb0be5cb09433af28b /meson.build
parentf8be3229b108c207035b8512fe3fe1d1c604e732 (diff)
parent531766fe642aec5270565ca885f423f4206c68a9 (diff)
downloadgtk+-baeae71d12d36c20f6dbe7d780bf5a8c55f4832a.tar.gz
Merge branch 'cross-postinstall' into 'master'
meson: Don't execute post-install.py if cross compiling See merge request GNOME/gtk!1636
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index bf63c1330e..d3b94574ab 100644
--- a/meson.build
+++ b/meson.build
@@ -797,11 +797,15 @@ subdir('docs/tools')
subdir('docs/reference')
# Keep this in sync with post-install.sh expected arguments
-meson.add_install_script('build-aux/meson/post-install.py',
- gtk_api_version,
- gtk_binary_version,
- gtk_libdir,
- gtk_datadir)
+if not meson.is_cross_build()
+ meson.add_install_script('build-aux/meson/post-install.py',
+ gtk_api_version,
+ gtk_binary_version,
+ gtk_libdir,
+ gtk_datadir)
+else
+ message('Not executing post-install steps automatically when cross compiling')
+endif
if host_machine.system() != 'windows'
# Install Valgrind suppression files (except on Windows,