summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2023-05-09 21:28:52 -0400
committerMatthias Clasen <mclasen@redhat.com>2023-05-09 21:34:05 -0400
commit5fbeea38708f13bd8e02a81f3c4dde64fd5d5c24 (patch)
tree180af595c32e9e08d8fe367f0983b975b0142b0e /meson.build
parent27368a418ad4ac8ecafbaa51db18531a5e5c160a (diff)
downloadgtk+-5fbeea38708f13bd8e02a81f3c4dde64fd5d5c24.tar.gz
build: Deprecate an option
Rename the demos option to build-demos, to match the other options for building optional parts.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index a7db954f7f..a46257faa6 100644
--- a/meson.build
+++ b/meson.build
@@ -753,7 +753,7 @@ subdir('gdk')
subdir('gsk')
subdir('gtk')
subdir('modules')
-if get_option('demos')
+if get_option('build-demos')
subdir('demos')
endif
subdir('tools')
@@ -860,7 +860,7 @@ if not meson.is_cross_build()
gnome.post_install(
glib_compile_schemas: true,
gio_querymodules: gio_module_dirs,
- gtk_update_icon_cache: get_option('demos'),
+ gtk_update_icon_cache: get_option('build-demos'),
)
else
message('Not executing post-install steps automatically when cross compiling')
@@ -901,7 +901,7 @@ summary('Documentation', get_option('gtk_doc'), section: 'Build')
summary('Man pages', get_option('man-pages'), section: 'Build')
summary('Testsuite', get_option('build-testsuite'), section: 'Build')
summary('Tests', get_option('build-tests'), section: 'Build')
-summary('Demos', get_option('demos'), section: 'Build')
+summary('Demos', get_option('build-demos'), section: 'Build')
summary('Examples', get_option('build-examples'), section: 'Build')
# Directories