summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-01-02 22:34:52 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-01-03 21:34:04 -0500
commit45bb4dc80c456618ff57caba24e7cf882b699347 (patch)
treeb84ec2784772d858a73f7bb9b919580b5059f52f /meson.build
parent51a6b29e0198560347183935a9caf6a768fa8e76 (diff)
downloadgtk+-45bb4dc80c456618ff57caba24e7cf882b699347.tar.gz
ci: Add a macos build
Most of this is cribbed from glib. We don't use COMMON_MESON_FLAGS here, since disabling -Werror one subproject at a time is too painful for all the promoted sub-sub-projects. This needs a better solution in meson. Since this is a full rebuild of the entire stack, limit this to master and merge requests.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 60e7729a8e..e8d6841116 100644
--- a/meson.build
+++ b/meson.build
@@ -381,8 +381,14 @@ epoxy_dep = dependency('epoxy', version: epoxy_req,
harfbuzz_dep = dependency('harfbuzz', version: '>= 0.9', required: false,
fallback: ['harfbuzz', 'libharfbuzz_dep'])
xkbdep = dependency('xkbcommon', version: xkbcommon_req, required: wayland_enabled)
-graphene_dep = dependency('graphene-gobject-1.0', version: graphene_req,
- fallback: ['graphene', 'graphene_dep'])
+if os_darwin
+ graphene_dep = dependency('graphene-gobject-1.0', version: graphene_req,
+ fallback: ['graphene', 'graphene_dep'],
+ default_options: ['introspection=false'])
+else
+ graphene_dep = dependency('graphene-gobject-1.0', version: graphene_req,
+ fallback: ['graphene', 'graphene_dep'])
+endif
iso_codes_dep = dependency('iso-codes', required: false)
gtk_doc_dep = dependency('gtk-doc', version: '>=1.33',