summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2017-09-06 08:33:18 -0400
committerMatthias Clasen <mclasen@redhat.com>2017-09-06 09:53:20 -0400
commitb5e00d36f084b827c48e4c9b8adc8fcedc14f2ff (patch)
treeb9e3c0601ca5983e4dcc094ed047cad63cccbf08 /meson.build
parentaf5d3e3299eac52ba14fe90232cff385e66176b5 (diff)
downloadgtk+-b5e00d36f084b827c48e4c9b8adc8fcedc14f2ff.tar.gz
Allow building without tests and demos
This is meant to cut down build time in flatpak and similar situations. Since it produces technically incomplete builds, we list these options in the status output at the end of the meson run.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 11 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 995680aa90..85f408cb7e 100644
--- a/meson.build
+++ b/meson.build
@@ -520,11 +520,15 @@ subdir('modules/input')
subdir('gdk')
subdir('gsk')
subdir('gtk')
-subdir('demos')
subdir('modules')
-subdir('tests')
-subdir('testsuite')
-subdir('examples')
+if get_option('enable-tests')
+ subdir('tests')
+ subdir('testsuite')
+endif
+if get_option('demos')
+ subdir('demos')
+ subdir('examples')
+endif
# config.h
configure_file(input: 'config.h.meson',
@@ -615,8 +619,10 @@ summary = [
'GTK+ @0@ (@1@)'.format(gtk_version, gtk_api_version),
'',
' Enabled backends: @0@'.format(pkg_targets.strip()),
- ' Documentation: @0@'.format(get_option('enable-documentation')),
' Vulkan support: @0@'.format(have_vulkan),
+ ' Tests: @0@'.format(get_option('build-tests')),
+ ' Documentation: @0@'.format(get_option('enable-documentation')),
+ ' Demos: @0@'.format(get_option('demos')),
'------',
''
]