summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-06-17 17:50:42 +0000
committerMatthias Clasen <mclasen@redhat.com>2019-06-17 17:50:42 +0000
commit94555371f51e11304dd7508a7f888c05651087bf (patch)
treed4dcd412448486240e9d39db5ca0ce93f64c60d1 /meson.build
parent47da5607e1234831cb6eb0803ba008351afd4bfc (diff)
downloadgtk+-94555371f51e11304dd7508a7f888c05651087bf.tar.gz
meson: print disabled backends in the final build summary
It's easy to miss what's not getting build otherwise
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 8 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index f2301aa082..ffcf9d88b3 100644
--- a/meson.build
+++ b/meson.build
@@ -130,6 +130,7 @@ wayland_enabled = get_option('wayland_backend')
broadway_enabled = get_option('broadway_backend')
quartz_enabled = get_option('quartz_backend')
win32_enabled = get_option('win32_backend')
+mir_enabled = get_option('mir_backend')
os_unix = false
os_linux = false
@@ -907,11 +908,14 @@ gtk_pcs = ['gtk+-3.0.pc']
gdk_pcs = ['gdk-3.0.pc']
pkg_targets = ''
-foreach backend: [ 'broadway', 'quartz', 'wayland', 'win32', 'x11', ]
+disabled_backends = []
+foreach backend: [ 'broadway', 'quartz', 'wayland', 'win32', 'x11', 'mir']
if get_variable('@0@_enabled'.format(backend))
gtk_pcs += ['gtk+-@0@-3.0.pc'.format(backend)]
gdk_pcs += ['gdk-@0@-3.0.pc'.format(backend)]
pkg_targets += ' ' + backend
+ else
+ disabled_backends += [backend]
endif
endforeach
pkgconf.set('GDK_BACKENDS', pkg_targets.strip())
@@ -962,8 +966,8 @@ summary = [
'------',
'GTK+ @0@ (@1@)'.format(gtk_version, gtk_api_version),
'',
- ' Display backends: @0@'.format(pkg_targets.strip()),
- ' Print backends: @0@'.format(' '.join(print_backends)),
+ ' Display backends: @0@ [disabled: @1@]'.format(pkg_targets.strip(), ' '.join(disabled_backends)),
+ ' Print backends: @0@ [disabled: @1@]'.format(' '.join(print_backends), ' '.join(disabled_print_backends)),
' Cloud support: @0@'.format(get_option('cloudproviders')),
' Colord support: @0@'.format(get_option('colord')),
' Profiler: @0@'.format(get_option('profiler')),
@@ -971,6 +975,7 @@ summary = [
' Documentation: @0@'.format(get_option('gtk_doc')),
' Man pages: @0@'.format(get_option('man')),
' Build tests: @0@'.format(get_option('tests')),
+ ' Installed tests: @0@'.format(get_option('installed_tests')),
' Demos: @0@'.format(get_option('demos')),
' Examples: @0@'.format(get_option('examples')),
'Directories:',