summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2020-04-29 07:42:38 +0200
committerJan Tojnar <jtojnar@gmail.com>2020-04-29 07:42:53 +0200
commit6d9db8610eff8c12d594d53b7813d9eea1247801 (patch)
treeed10c67e15d773f417e51ca2269666679741a59a /meson.build
parentac3d3c647e42c6e2232767de310978a6906ec7b3 (diff)
downloadgtk+-6d9db8610eff8c12d594d53b7813d9eea1247801.tar.gz
build: clean up .pc generation
Path concatenation is much nicer than the unwieldy format method. Since paths returned by get_option are relative to prefix, they will be joined as before. As a bonus, this fixes weird platforms like NixOS that actually pass absolute includedir under a different prefix.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 12388f743a..fcd3fe2052 100644
--- a/meson.build
+++ b/meson.build
@@ -720,8 +720,8 @@ pkgconf = configuration_data()
pkgconf.set('prefix', get_option('prefix'))
pkgconf.set('exec_prefix', '${prefix}')
-pkgconf.set('libdir', '${prefix}/@0@'.format(get_option('libdir')))
-pkgconf.set('includedir', '${prefix}/@0@'.format(get_option('includedir')))
+pkgconf.set('libdir', '${prefix}' / get_option('libdir'))
+pkgconf.set('includedir', '${prefix}' / get_option('includedir'))
pkgconf.set('GTK_API_VERSION', gtk_api_version)
pkgconf.set('VERSION', meson.project_version())
pkgconf.set('GTK_BINARY_VERSION', gtk_binary_version)