summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2020-05-27 14:53:10 -0400
committerRay Strode <rstrode@redhat.com>2020-06-05 10:01:13 -0400
commit10f2b11fda3cd3d92d8333babbeb4e8ca2dbea16 (patch)
tree23d54c683331b57fdf0a3afe53b292a24b51559b /meson.build
parentea1cc4b99109029d9fdf7c98b73a9c3997c44901 (diff)
downloadgtk+-10f2b11fda3cd3d92d8333babbeb4e8ca2dbea16.tar.gz
x11: Add back support for the damage extension
commit 14bf58ec5dfdf19e3ca603b977626608dafc729b dropped support for using the DAMAGE extension since there was no code that needed it. We're going to need it again, however, to address an NVidia vendor driver issue. This commit does the plumbing to add it back.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9295163603..a8a3c7cdbe 100644
--- a/meson.build
+++ b/meson.build
@@ -501,6 +501,7 @@ if x11_enabled
xi_dep = dependency('xi')
xext_dep = dependency('xext')
xcursor_dep = dependency('xcursor', required: false)
+ xdamage_dep = dependency('xdamage', required: false)
xfixes_dep = dependency('xfixes', required: false)
xcomposite_dep = dependency('xcomposite', required: false)
fontconfig_dep = dependency('fontconfig')
@@ -513,6 +514,9 @@ if x11_enabled
if xcursor_dep.found()
x11_pkgs += ['xcursor']
endif
+ if xdamage_dep.found()
+ x11_pkgs += ['xdamage']
+ endif
if xfixes_dep.found()
x11_pkgs += ['xfixes']
endif
@@ -523,6 +527,7 @@ if x11_enabled
atk_pkgs += ['atk-bridge-2.0']
cdata.set('HAVE_XCURSOR', xcursor_dep.found())
+ cdata.set('HAVE_XDAMAGE', xdamage_dep.found())
cdata.set('HAVE_XCOMPOSITE', xcomposite_dep.found())
cdata.set('HAVE_XFIXES', xfixes_dep.found())