summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-03-22 15:16:14 +0100
committerChristoph Reiter <creiter@src.gnome.org>2019-04-11 16:45:36 +0200
commitb185f69334382820fa3675bb5925d2f6455fc5df (patch)
treee0046d142be3ca7bd22de34e16e2f503004a03a0 /meson.build
parentca3385579332add78553e287d4239e5401ae66a7 (diff)
downloadgtk+-b185f69334382820fa3675bb5925d2f6455fc5df.tar.gz
meson: check for and set HAVE_IPRINTDIALOGCALLBACK
It's needed under mingw in the print backend
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a90c93fb8e..54c3a4304a 100644
--- a/meson.build
+++ b/meson.build
@@ -707,6 +707,12 @@ else
endif
endif
+if os_win32
+ if cc.has_header_symbol('windows.h', 'IPrintDialogCallback')
+ cdata.set('HAVE_IPRINTDIALOGCALLBACK', 1)
+ endif
+endif
+
if os_unix
cdata.set('HAVE_GIO_UNIX', giounix_dep.found())
endif