summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWilliam Roy <wroy@proton.me>2022-09-26 19:52:57 +0000
committerWilliam Roy <wroy@proton.me>2022-09-26 19:52:57 +0000
commit872e04f94eb61e213ad586072aee42e9b5ba38ed (patch)
tree18564be34a481f9aac7abdab37b162f0f0cb9476 /meson.build
parentd5c60438d1ccc599bca12b35e5fb65a8950332d4 (diff)
downloadgtk+-872e04f94eb61e213ad586072aee42e9b5ba38ed.tar.gz
Fix preprocessor conformance with MSVC
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1f3ac591f3..035efb2422 100644
--- a/meson.build
+++ b/meson.build
@@ -256,6 +256,7 @@ if cc.get_id() == 'msvc'
'-FImsvc_recommended_pragmas.h',
'-D_USE_MATH_DEFINES',
'-utf-8',
+ '-Zc:preprocessor'
]
add_project_arguments(cc.get_supported_arguments(test_cflags), language: 'c')