summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2020-10-09 20:08:23 -0700
committerMatthias Clasen <mclasen@redhat.com>2020-10-14 15:06:12 -0400
commitfb02c9986856adad15348e8502cd4b9ae76741c2 (patch)
tree2c495f11656343d3f1e0762bc30ac3d7d24f68c1 /meson.build
parent036b56a43bf349ec9775ff8e22d801b6b369d04f (diff)
downloadgtk+-fb02c9986856adad15348e8502cd4b9ae76741c2.tar.gz
macos: port gtk to GDK_WINDOWING_MACOS
For the various uses of GDK_WINDOWING_QUARTZ, we need to use alternatives from GDK_WINDOWING_MACOS. Some minor loss of functionality is here, such as icons sent with application menus. That can certainly be added back at a future point.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 85a605c2c9..40f31f9f3c 100644
--- a/meson.build
+++ b/meson.build
@@ -113,7 +113,6 @@ os_unix = not os_win32
if os_darwin
wayland_enabled = false
else
- quartz_enabled = false
macos_enabled = false
endif
@@ -418,7 +417,7 @@ pc_gdk_extra_libs = []
cairo_backends = []
foreach backend: [ ['cairo-xlib', cairo_req, x11_enabled],
['cairo-win32', cairo_req, win32_enabled],
- ['cairo-quartz', cairo_req, quartz_enabled],
+ ['cairo-quartz', cairo_req, macos_enabled],
['cairo', cairo_req, broadway_enabled or wayland_enabled], ]
backend_enabled = backend.get(2)
cairo_backend_req = backend.get(1)
@@ -591,7 +590,7 @@ if broadway_enabled
backend_immodules += ['broadway']
endif
-if quartz_enabled
+if macos_enabled
pc_gdk_extra_libs += ['-framework Cocoa', '-framework Carbon']
backend_immodules += ['quartz']
endif
@@ -814,7 +813,7 @@ pkgs = [ 'gtk4.pc' ]
pkg_targets = ''
display_backends = []
-foreach backend: [ 'broadway', 'quartz', 'macos', 'wayland', 'win32', 'x11', ]
+foreach backend: [ 'broadway', 'macos', 'wayland', 'win32', 'x11', ]
if get_variable('@0@_enabled'.format(backend))
pkgs += ['gtk4-@0@.pc'.format(backend)]
pkg_targets += ' ' + backend